Apscade Web Builder

Web browser requirements for accessing Apscade built websites

We recommend that you install the latest web browsers and keep them up to date. Versions of Internet Explorer older than version 9 do not support today's website standards. To ensure you can view all websites correctly please use one of the below web browsers:

Windows XP users please use:

Update to Windows 10 recommended.

Windows Vista, Windows 7,8 or 10 users please use:

Mac users please use:

  • Safari; or
  • Firefox

iPhone, iPad and Android users please use:

  • The device's default browser; or
  • Google Chrome; or
  • Firefox

Unsupported browsers

Some Apscade sites may support a text mode. This mode displays the site in its most basic form if your web browser is unknown to the site and cannot render html5 content. This mode may still require a basic web browser with html rendering capability, cookies and https support.

Keeping up to date

To avoid cyber intrusions and view the latest web sites/apps you should keep frequently used software up to date. This includes but is not limited to: Your virus scanner, Adobe Flash Player, Adobe Reader, your web browser and plugins, and your Operating System.

Contact Us

Apscade
enquiries@apscade.com

Please Note: This site uses cookies. You can disable cookies in your Web Browser settings.
This website is best viewed with